Where does the AUV3 put .wav files and how can i delete them?

i have an auv3 instrument of mirack loaded in apematrix on my iphone. from a flash drive, i loaded a rather large file into the cf player module as a test to see how mirack would handle it. i then removed the flash drive and restarted the patch but the file is still there in the cf player module (even after rebooting my iphone its still there). it seems mirack copied the file to some hidden place on the phone. i cannot find this file anywhere in the file browser (not from the browsers inside the mirack auv3 or via the files app). it’s a large file and taking up space - how can i find/delete these files?

Very strange, I wonder if it’s being held in RAM. I can only think to ‘initialize’ the cf player

?
hope you can find it.

i rebooted the phone- that should technically clear the ram. but also i found that older files i had added into the cf player auv3 (that i’ve long since deleted from this phone) are still there accessible via the + and - buttons on the cf player. also the impulse response files i’ve added to the niythsi convolution reverb are, interestingly, accessible in the cf player as well. using those + - buttons. so my guess is that any .wav files added to modules within the auv3 - those get duplicated somewhere hidden. i definitely need to be able to delete some of these and clean house since my phone doesn’t have a ton of storage space left…

i also notice that when i load patches i made from the regular mirack into the auv3 - any modules that call .wav files (files from the mirack app’s folders) they’re are all missing the files in the auv3. so this also makes me think the auv3 is looking for files in some alternate universe reality.

I don’t use AUv3 because it can be head scratching tetchy most of the time, this is another example. I only use Cubasis 2 when I need a DAW but have had problems with most AU synths and Fx… Cubasis 3 is worse !!
I’ve had most success when keeping AU synths and fx to basic automation and rendering midi parts to audio. If I create patches or sounds whilst in AU midi track on Cubasis, problems tend to happen.!

Sorry I’m not much help, all the best

Note_that flash ram can keep stuff, even after an on/off reset (reboot)… I thought ‘initialize’ would clear the (flash) ram.

I’m bumping this thread up again as I’ve done the same test with cf player (I got a warning that my wav files are going to be copied into miRack folder) however I can find where are imported wav files stored in the AUv3 version and more importantly how can one access/delete them. @pronvit any insight on this please? Thank you!

Hi @jsmonzani, to delete samples from miRack go to the main SETTINGS (apple app that we all have), select GENERAL and tap on iPAD STORAGE… .Scroll down to miRack, tap on miRack and below the ‘delete app’ button is a list of all samples in miRack… TAP on the small ‘EDIT’ button to show ‘red minus’ and select the sample/s to delete… confirm delete and you’re done .
To access samples in miRack (for editing, bouncing and such) I use AUDIOSHARE.

2 Likes

Thank you for the detailed instructions @Runcell, never used that before and it solved my problem. That’s great!

I love Audioshare too. I wish one could send a sample from it to one of miRack’s samplers but this seems rather complicated to implement!

1 Like

Sending samples from AudioShare is totally possible @jsmonzani… it’s more the other way around - you import samples to the sampler from AudioShare.

Create a new sampler in miRack (I use Nysthi, mostly) and double tap it to bring up the menu. . . Tap on load sample… note the name of the folder you are now in - at top- and next to that (on left, I think) is a small blue arrow - Tap the blue arrow to come out of current folder… and you should now see AudioShare on the left hand side… Tap to enter folder, select sample - tap to load.
Phew ! Hope that makes sense…

@Runcell what about deleting samples loaded into the auv3?

i have mirack as an auv3 inside of ape matrix. then i loaded a file called x.wav into the cf player sampler in the mirack auv3 instance. but x.wav now does not show up under general<iphone storage<micrack like you described (x.wav is also not showing up anywhere in apematrix or the main mirack folder). but x.wav is now always there still whenever i load cf sampler inside the auv3 and use the + and - buttons of the cf player to cycle through the available samples. where are those auv3 samples being stored and is there a way to remove them?

I see… initialise does not work for me also. The only way I could clear a sample is by loading a new cf player… but for you, even then the sample is still there.
I would try re connecting the drive that the sample was loaded from…and… load another cf player… mess with +/- buttons, delete cfplayer disconnect drive and open new cf player & visa versa !! Then try same again in stand alone… I’m not really sure to be honest, it’s strange.

Cf player is also a little buggy on iPad - when using +/- buttons…
and as for AUv3, I’m not sure what’s going on there, every time I use it I end up problem solving instead of making music… not just miRack but all apps - SugarBytes Cubasis Moog…
…best not get into a rant, I hope there’s something there that leads you to a soloution.
All the best

@Runcell - also when i load a sample “x2.wav” into any of the other samplers in the auv3, for example the nythsi ones - even after fully deleting x2.wav from it’s original location and a full reboot of my device, x2.wav still shows up via the cf sampler’s + - buttons. i also noticed that the nythsi convolution reverb - loading impulse response .wav files into there - those .wavs too also show up in the cf sampler via the + - buttons. so it seems any .wav file loaded into any auv3 mirack module that accepts .wav files- those get copied to some place unknown.

i recently spoke alexander zolotov, the creator of sunvox - about where sunvox’s auv3 samples were stored and he said that apple keeps those in a special location not accessible from the files app (so he built in a wifi localhost option to access/manage those auv3 .wav files via safari).

are there any other ideas on how i can get rid of these unwanted .wav files? i have a lot of large files i loaded in during initial tests i was doing with the sampler modules. i’m trying to get ready for a big live set at a decent sized festival and i’d love to use mirack heavily (because it’s an awesome app!) but unfortunately im running out of disc space on this device :frowning:

Alexander Zolotof is a very clever guy (I have nearly all his apps) and what he says makes sense, besides we all like to blame apple.
I wonder if he could make a host available on App Store to access all apps AU wav. files… may be worth an ask.

The only advice I can give is to try re connecting the drive and avoid making patches/loading samples etc whilst in AUv3… Make all patches and load all samples in standalone, save it then load it up in AU. I don’t even record via AU, I record using samplers, within miRack, save it then import the wav. to Cubasis… because AU is problematic every time with every app i try.

I will have a another look to see if there is any other ways of deleting wav. files, I would also avoid cf player for now and report a possible bug to Vitaly.

Sorry I can’t be of much help, all best

unfortunately cf player is one of the most cpu efficient ones (at least on my device) and easier to use so can’t avoid using it for now since i’ve already got way too many patches using it. and again, any and all modules in the auv3 that load a sample, do this ‘automatic copying them to a secret folder’ - so even if i use another sampler, im up against the same problem. also, am not using external drives so i can’t test out your idea. everything is done within this one mobile device here.

i think reporting a bug to vitaly makes the most sense. what is the best way to report a bug? through this forum or?

also i will definitely mention that idea to alexader although i think he said that the ability to access from localhost to the auv3’s secret folder -has to be built into each auv3 itself.

also i did actually just realize that, you can load in a smaller sample with the same exact filename and it overwrites the older version. so this is one dirty solution - at least to free up file space. but it still doesn’t allow one to remove these files altogether.

That’s a great, like you say ‘dirty soloution’ @offthesky. That’s freed up space… What is your AU host ? Because I always have problems in Cubasis 2 and Cubasis 3 is somehow worse !

Ah! ApeMatrix…!

Thanks for the detailed instructions on loading samples :slight_smile: Much appreciated!

1 Like

Thanks @offthesky , I wasn’t sure the previous solution solved the AUv3 “where are my samples loaded?” problem and it seems it doesn’t as I thought.

I’ve backed up my patches, deleted and reinstalled miRack, and carefully loaded a single small sample into cf player. I can confirm all other samples were deleted (or at least, they don’t show up). Hope this can fix your problem. Did you try this?

Here’s also the warning that you get the first time. There’s an indication of the destination Imported hidden folder but nothing more we can do.

Finally, I use AUM and only had one crash (and honestly with modules that weren’t stable in VCV either).

1 Like

Thanks for the pic @jsmonzani, I did consider suggesting a re install, as a last resort… as time consuming and stressful as that can be !

To access the ‘imported’ folder from within miRack, drop down the patch menu (load/save menu) Tap on ‘Open existing’ and hit the blue arrow (browse) once or twice to expose the browser (on left hand side)… Select iCloud Drive… and within the miRack folder is another folder labelled ‘IMPORTED’. . Could the samples be in here ? I could not find a folder labelled ‘Documents’ though !

1 Like

Also, the pop up notification suggests/recommends copying your samples to MiRack folder manually to avoid this.
If I am using samples from an external drive I always copy them onto the iPad first. I save them in AudioShare so that I can load them in from miRack. I’ve never had these issues and I always know where to access my wav.s … I would never stream samples from an external drive.

Thanks! I see a difference between us and it’s interesting: I’m storing files locally and not on iCloud. So for me, the miRack folder is local (nothing on iCloud), and there’s no “Imported” folder in it.

I’ve previously tried to copy my WAV file to my local miRack folder, import it in cf Player and then delete the local file: it’s still available on cf Player, suggesting that it’s staying somewhere.

Well I’d say: let’s avoid cf Player and go for NYSTHI’s ones for the time being. FYI, I had issues on VCV Windows with cf Player in the past, and never used it since then. There might be something fishy in there…