miRack no longer runs after update

Hi there!

Been using miRack for a couple of years now (iPad and MacBook Pro) and love it. One problem though. I upgraded to 3.8 last night (MB Pro) and have not been able to start miRack since then. Tried uninstalling and reinstalling several times with no change. The error I get is a dialog box that proudly proclaims:

miRack quit unexpectedly

Click Reopen to open the application
again. Click Report to see more detailed
information and send a report to Apple.

That’s it. miRack doesn’t even begin to load, really. System specs are 2014 MB Pro running Big Sur 11.7.10

Anyone who can shed some light on this, please feel free to do so. I can post more information from the terminal file if necessary.

Also, I did try to see if a previous version (3.7.2. preferably) is available but no such luck, as it seems to be Appstore only.

Any help that can be provided is much appreciated.



I have the same issue. I tried to report it using the support link in App Store but when I press submit I get “Submission rejected” :frowning: