MIDI clock input question

So, I am real pleased with how well MiRack works and sounds. I seem to be having an issue with using an external clock when using an “external” app or hardware. I have attempted to use Gadget, and Drambo, both with and with out Ableton Live engaged and both nested in and not nested in AUM. While the MIDI input module seems to work in so far as gate/trig and v/oct outputs, the clock and starting/stopping sequencers seems to not reliably function, this makes it difficult to sync sequences playing on other apps with sequences playing in MiRack.
Similarly, I have most recently been using an Elektron OctaTrack to control MiRack. Again the MIDI input module of MiRack does very well at converting incoming MIDI to v/oct and gate/retrig info. Further, I managed to figure out a decent method to start and stop clock/sequencer modules in MiRack with starting and stopping the OctaTrack Sequencer. However, clock data seems to not be coming through, so the BPM of clocks or sequencers in MiRack does not track with BPM changes in OT. Is this a known issue or am I doing something wrong?

I’m not sure if you are doing this already, but for clocks to sync to AUM tempo they need to be controlled by the hos tempo sync from the “host sync” module. Once loaded as AUV3 ableton link is unneccesary as far as i can tell.

If you need to sync completely unsyncable things you could use a midi channel (16 for instance) and use it to send quarter note pulses to a clocked module, hence syncing the two devices. Seems to be an ok workaround, though the host sync module obviously works better.

I will check that out, but in the case of using the Octatrack, I did not have an instance of Octatrack and an instance of MiRack in AUM. I was just running MIDI from the OT straight into my iPad and had a MIDI-to-CV module in MiRack. In that case a clock signal does not seem to be coming out of the clock output of that module, whereas CC, start/stop, gate, and v/oct signals do.

Ahh in that case, have you set AUM to sync to the external clock from the OT?

(Beautiful piece of kit the OT, used to own one, really considering getting another one :slight_smile: )

Right, but is there a way to do it without going through AUM? The window for viewing is the modules is so much smaller in AUM.

The OT seems to be a nice interface for MiRack. It has 8 channels of MIDI out. Each channel can output MIDI on a different MIDI channel to a different MIDI input module for sequencing if you want. Each channel has 13 MIDI CC number assignable knobs that you can map to different knobs, sliders, buttons in MiRack. Each channel also has three LFOs that you can assign to any of those particular CC number knobs. In all you can map 124 assignable knobs to MiRack parameters via the MIDI learn feature.

What kind of midi interface are you using(The Octa doesn’t have USB midi right)?

Will check the setup i have used with in a similar fashion with the OPZ and Mirack if it is any help

I am using a Cake Walk MIDI to USB adapter to camera adapter to iPad set up.

(I dont have the OPZ with me at the moment, i can check my setup when i get hold of it in the weekend)

Are you not receiving MIDI clock in miRack at all or is it unreliable? As I understand, it’s unreliable with Gadget and you’re not receiving clock from OctaTrack, right?

Thus far, I have not been able to get the MIDI input module to properly/reliably pass on a clock signal to a clock module using any method, either via AUM or just connecting the two devices (virtual or physical). It has sort of worked when connecting Drambo to MiRack via AUM or Ableton link. However, I do not prefer working with AUM at least when putting together a modular rack because the size of the window in MiRack is smaller and just harder to navigate.

What I have been trying to do most recently is use MiRack and get it to play nice with the Octatrack without an intermediary app (basically because I am considering getting rid of a fair amount of physical Eurorack gear because MiRack seems to really recreate the experience for me). I am able to put a MIDI input module in the rack, set the MIDI channels so that it sees the Octatrack and get a everything working together pretty well. So, MiRack is getting v/oct, gate, retrig, pitch wheel, MW and start/stop CV coming from the MIDI input module when the outputs from that module are connected to the proper inputs of downstream modules. However, the clock signal does not seem to be working when connected to clock inputs on clock or sequencer modules. Things seem pretty synced up when I manually adjust clock or sequencer modules to the same BPM of the Octatrack, but I would love to be able to adjust clock speed in MiRack from the Octatrack.

I’m sorry to have come late to this discussion (memo to self- put down miRack occasionally and look at recent posts) because it is not dissimilar to the one I’ve been having in AUM. I tend to have the Clocked module informing a sequencer running into an Audible Instruments module- Plaits say- and an instance or two of Frozen Wasteland‘s rhythm sequencer, and while I can (now) start and stop the modules with AUM’s transport controls, I cannot sync the start points of the rhythm and melodic sequences. Connecting the modules to ‘reset’ and then hitting ‘reset’ on Clocked simply does not reset both/all modules to their start points.

Additionally, it is impossible to get AUM to start recording at the start of a sequence either. My preferred workflow is to record in AUM, then transfer via Audioshare to Cubasis. Where I’m simply recording drums in miRack the fact that recording cannot be made to start at the beginning of the pattern can be worked around- simply trim the ‘false start’ off the drum track in either Audioshare or Cubasis itself- but not being able to sync rhythm and melodics precludes recording them together. The only possible workaround there would be to run miRack in two channels in AUM, record separately, then sync manually in Cubasis, but it shouldn’t be necessary. Should it?

Can you share your patch or a screenshot of it (showing clock-related connections)?

Pics as requested. As you will note, there’s nothing complex about the patch- just Plaits and drums- but they will not sync with each other, nor with AUM’s transport.

Hope you can help. I’ve got a dozen patch ideas just itching to be transferred to Cubasis and layered with other bits and pieces…

Hi r05c03,

Did you get it to work with your octotrack ?

I use directly my Digitakt to feed the “Clocked” module into MiRack. I have the same issue with the clock input from the Midi Input module. I think it comes from the electron clock resolution.

But anyway, my solution is to take one Midi track (say the 16th) on my Digi, put on every steps (quarter notes), and send it to Mirack. Instead of using the “clock” signal from the Midi Input module, use the “Gate” and send it to the “BPM” input of “Clocked” module. Make sure the BPM mode is P4 on the “Clocked” module.

This way I have a decent clock, and I have the transport controls directly from the Digitakt, since in P4 mode “Clocked” module activate “Run” only when receiving something in the “BPM” input.

Let me know if it’s not clear enough !
Hope it helps,

I don’t have Digitakt or Octatrack, but I have another piece of hardware that can output MIDI clock. It works right away if I set the same clock resolution on the hardware and in Clocked (using MODE buttons). The only problem is that you also need to synchronise clock start (so that Clocked knows when to start counting the specified number of clock pulses) - usually you connect START MIDI output to RESET Clocked input for this.

Where do you find the “host sync” module?
Been using miRack on an iPad Pro. Fantastic. I’ve been able to get audio from there into Cubase on my Mac Pro, but haven’t been able to sync miRack to Cubase (so that miRack plays in sync with other tracks in Cubase).
Might be the wrong place to post this, but not finding an answer to this fundamental question anywhere else. Thanks, Joe.

1 Like

Currently, with Cubasis, when play is pressed (on Cubasis) then MiRack/CLOCKED will play… but when Cubasis is stopped MiRack/CLOCKED will continue playing…press play again on Cubasis, and MiRack will stop but Cubasis is playing… stop Cubasis and MiRack will play…
Essentially MiRack is only receiving one out of every two triggers.

I’ve got it…

Double tap on CLOCKED and tick MOMENTARY RUN INPUT.

Yeah RUN input is confusing because by default it’s basically START/STOP. I had to add this Momentary Run Input option which the original module didn’t have so that it could be used with the host sync module.

Yes momentary run, I’ve used a few times, works well. Often forget about it. And yes run is just trig on start and trig on stop, quite useful though.

Yeah, I never got the momentary Run option.

But I haven’t used the host sync yet.