Midi CC routing to Bitwig


I’m using Mirack setup as a 16ch multioutput plugin on a hybrid track.I want to send CC from the midi CC output module in Mirack to bitwig to control some of the plugin parameters.

I’ve set the Midi input to Mirack on the channel that I want to automate and set the midi to all in and Same but I can’t get it to work.

I am able to receive note data and assign that freely with the appropriate midi out module in Mirack.

I’ve used the same patch with another daw and was able to get CC to that daw. Is there some thing else to consider while setting up midi with Bitwig?


Hi, im using midimittr and streambyter to do that. Midimittr to route to other equipment and streambyter to manipulate the signal.
Without midimittr i had to much problems

Care to send the patch?
Not quite sure what’s not working. Maybe I don’t understand what you’re trying to do.

Another option is to use the Note Receiver. That way, you can still use other MIDI ports on that track.

(Was also experimenting with a Note Grid on the same track as miRack. Not needed.)

Thanks Enkerli,

I got the midi detection to work by adding a keyboard controller preset in the controller menu. and assigning it via the add controller or key command. that enabled miRack to hear the midi cc using IAC Driver, but when I add midi CC modulator it does not seem to detect the midi cc from mirack. the only work around seems to be to add a Note FX midi CC parameter and then some how assign the knob to midi cc modulator.

I find this strange, its should work directly from the host app as your picture would suggest.

Could there be a midi conflict or something? I have midimittr but I have it turned off for now.

Thank FemdoTon,

I have Midimitter to route as well I’ll give that a go.

I don’t use midimittr (didn’t realize it was on macOS). And I almost never use the IAC Driver destination.

A conflict isn’t out of the question. Have you tried different CCs? I did notice that some Bitwig devices might not respond to certain CCs. Also, there can be some weirdness in terms of the “controllers” (in Bitwig settings). So, if you’ve assigned the IAC Driver to a generic controller, that might be part of the issue.

A screenshot or something might help.

In terms of using Note FX or a modulator, it works really well. It’s not so much a workaround as the Bitwig way. In fact, Bitwig converts MIDI signals to audio rate which means that you can literally use LFOs for FM. Polarity has several videos about this. This one is rather wild:

If you can’t make things work, it might make sense to ask on a Bitwig group, since it probably doesn’t have much to do with the way miRack handles things. The main Facebook group I know has been taken over so Discord is probably the best place, right now.

Yes I’ve tried different CCs, no other midi ports seem to work except the IAC out from the midi module in MiRack. I cant get the midi cc to flow in without assigning a midi keyboard controller and giving it the IAC Driver input. The host driver does not show up as an option there.

It’s quite perplexing. do you have a midi controller assigned in your settings ? it appears that you are using the host driver to send midi cc out to bitwitg, seems like it works for you.