Issues with crashing

I’m having issues with the app crashing quite regularly after the ,ast update. Previously had no issues but it’s happening a lot at the moment, has happened when I added new modules or changed parameters within a patch. Doesn’t seem to be any pattern to it. Ive removed the app and downloaded it again from the App Store but still the same problem.

Sometimes when it crashes I have to turn off my iPad and turn it back on again to sort it out. Just freezes and remains frozen until I turn it off and on again.

Anyone have any ideas?

I tried mi rack for the first time today and after a while I have no sound output. every devices stops working lfo, sequencer etc…
iPad Pro M1

Thom, does it crash or freeze? Also, what device do you have?

1 Like

Hey,

It freezes would be a better description. It freezes and all sound stops. If I’m using something like the bogaudio mix 4 the input slider lights will stay lit until I close and reopen, at which point nothing shows any signs of life and the lights on the sliders are dark. If I leave it for 5 mins or turn off and on again it works. I can’t see any discernible pattern right now, no particular modules or changes. Like I said, no issues until the last update when the menus went funny for me. After I updated the problem started.

I’m on an iPad Air 4.

I turned background audio on as it had turned off when I reinstalled.

It hasn’t frozen since then. I’ll update if it happens again.

Edit: closing and coming to post this and it has frozen again.

Ok, the more I play the worse it seeming to get. I deleted all of my patches and deleted it off my phone just in case it was some kind of conflict. I’ve started building new patches and It happens when I add new modules or change parameters in patches.

Could it be something to do with the auto save?

I’m also having crashes, right after the start up, basically it doesn’t open up on my macbook pro on Catalina 10.15.7 (runs on an old mac pro mid 2010 which is not officially supported by apple but catalina works great on my old machine)

Wanted to test it for the first time but the error message like “mirack unexpectedly close”

Hey, just letting you know I’m investigating this. I’ll post an update once I’ve found the problem or need more info.

2 Likes

Great thanks! Love how commited you do this and can’t wait to test mirack! Glad to deliver more info if needed. I updated to catalina just because of mirack :slight_smile:

@pronvit
I’m not sure why this might be relevant but I’ve realised I started using an audio interface just before the last update. Ive also just realised that every time I have the freezing issue (been happening a lot) it’s whilst using the iPads built in speakers but it hasn’t happened at all whilst I’ve been using the audio interface.

Thanks for the info. The “problem” is that I didn’t change anything in either audio or engine code, so don’t know why it suddenly started happening for you…

@pronvit
Yeah, I’m beginning to suspect it’s an iPad issue rather than a mirack issue.

Problem solved (I think). The freezing appears to have been connected to iPhone/iCloud backup failing. Once I resolved that I haven’t had it freeze since.

:sunglasses:

Oh wow that’s a weird connection. Thanks for letting me know!