[Fixed] Host Sync module clock at 2048 samples/buffer

I found a bug in the host sync module when using miRack v3.59 as midi AUc3 FX in AUM and AudioBus with 2048 samples/buffer on an iPad Pro 10.5 with IOS 13.6

How to reproduce:

  • Load miRack as midi AUv3 either in AudioBus or AUM
  • Direct the midi output of miRack to any synth just for an audible reference
  • In miRack AUv3, add a Host Sync Module, a Midi Trigger Output module and maybe a submarine LA-108 Logic Analyzer module
  • Connect the clock output of the host-sync module to a note in the trigger module and also to the logic analyzer
  • When starting the hosts timeline with its play button, a note is played at regular intervals and the pulse is visible in the analyser. (Adjust the timing to see several pulses at once)
  • This works correctly for 64, 128, 256, 512 and 1024 sample buffer size and both 44.1 and 48khz.
    => But with a buffer size of 2048, the audible timing is irregular and the analyzer shows several short spikes inbetween longer pulses.

Additional info:
I verified this error in both hosts - the bug is also independand of the clock-rate setting of the host-sync module.

To be sure, i cross-checked with an iPhone XR on IOS 14.7.1 using AUM and fixed 48khz sample rate. There the analyzer showed short spikes just before or after the regular pulses, The irregularity is most prominent when setting the host-sync modules clock rate to Beat/8.

The bug also existed in the previous version v3.58.

Regards, -ki

Thanks, will be fixed in the next update.


I can confirm that the 2048 samples/buffer setting is working correctly with v3.61. Thanks a lot for fixing.

(I tried to change the topic to [Solved] Bug: but didn‘t find that option)