Can’t upload samples in iOS 15

Hi, I have a problem with the latest version of miRack on ipad 2021 with ios 15. The loading of samples works very poorly, in fact, the file manager simply does not open, only minimizing the application helps.

I sent the video to the support email, but did not receive a response

MiRack 3.67

iPad 9 generation

iOS 15.1

Hi there,

Sorry I didn’t reply to the email. I’m investigating this issue, which I initially thought was related to iOS 15 or 15.1, but I wasn’t able to reproduce it myself with either of these iOS versions. I’ll keep trying to find what’s causing it.

Which Sampler are you using?

I tried on the phone, there’s iOS 15 and caught the same bug. Let me know if I can help in any way.


I found that I can upload a sample from local, but it won’t load a sample from any cloud account. I tried both one drive and drive. It shows the files, but never pulls the sample file into the module. Both in complex simpler and quad simpler

Welcome and Merry Christmas @Dariusprimium.

Try importing your cloud or one drive sounds to the miRack (local) folder OR Audioshare, first.

Then hit load sample on the sampler you are using (within miRack) and locate the miRack (or AudioShare) folder that contains your samples.

I hope that’s all there is to it, all the best.

I am also having trouble loading samples. I have iOS 15.3 on an iPad mini 6. Selecting load samples from the drop down menu freezes the app so I have to quit to select anything else.

seems like the best option is to save samples to the miRack local folder + launch miRack + load from the local folder