AUv3 Error Crashes Logic


Whenever I have multiple or heavy instances of miRack in my Logic project, it always hangs and doesn’t open when I try to open the project again. The I try “command+Option+Esc.” is says “AUv3 error” and both miRack and Logic Pro not responding. Otherwise the app works like a charm.

Is this a known issue you’re trying to fix, or something I’m doing wrong?

I would love to use this app more for my projects but this bug is really scary, I don’t when I just won’t be able to open a project after I save it. I have actually lost of a few projects because of this.

Could you clarify what you mean by [quote=“skm, post:1, topic:615”]
multiple or heavy instances of miRack
[/quote] Maybe do a test and save a project firstly with one instance, then two and so on.

So in this project I’m only using two instances of miRack… “Instance A” is being used as en effect plug in, pasting pic:

[Uploading: Screenshot 2021-06-08 at 4.21.47 PM.png…]

Instance B is being used as a MIDI instrument, pasting pic below:

So when I only had Instance A I had no problem with this project, it used to open up without any issues.

But as soon as I introduced Instance B, it stopped opening and started crashing. I had to force quit AUv3 Tool to start the project and now have to keep removing this instrument from the project before closing it.
I add it, make changes, record it to audio, and then remove it so I can open the Logic File again.

Thanks for looking into this! Please let me know any other way I can help, I really hope this made things clearer!

Sorry, I can only see one pic.

Can you give more info about your Mac and the Mac OS. Also, where are you saving your miRack patches

FYI, I just had a Logic project with two miRack instances, one instrument and one as an AUX FX. I saved and loaded and it was okay. But then, that is all I had.
I have decided to have all my miRack patches in a folder in Documents. This seemed to cause all kinds of issues for a week or so - crashes, items not loading - but then things settles down.

Btw, I am using Catalina.


Oh sorry, uploading it again, I don’t know it didn’t upload the first time…

I’m using an MBP 2018 2.6Ghz 6-Core Intel i7.

Running the latest OS Big Sur 11.4

I have saved all the patches in the Users/Music/miRack

So the FX instance is not a patch, I built it in Logic itself. The instrument IS a patch I had built earlier and then brought it into Logic.

Is it a common that if you save all your patches in one folder it can cause issues? Is this a thing??

Every thing looks good to me.

As an experiment, could you remake the effect patch in miRack standalone and then import it into an fx instance in Logic and save the Logic project with that version to see if it loads.

I do have load issues sometimes when I switch between standalone and a plugin version.

I’ve had this same experience before with instruments that I’ve created within logic too (without saving it as a standalone patch).

I tried creating a new Logic Project with these two patches like you asked, still the same issues are coming up.

In fact, now even my FX patch is creating problems (in my original project), but I’m able to re-start logic and it start properly, while the instrument patch is still an issue.

Can there be an issue with my Logic instal or AUv3 instal? Do you think re-installing these would make a difference?

I am now at a loss. The only thing I could suggest is putting the two patches in a folder and zip the folder and see if you can attach that here.

@pronvit maybe you can help?

I’ve always had problems when creating a new patch within AUv3 set-up… much more success when creating a patch in standalone then loading that in as AU instrument/fx… I’m on iPad not Mac, but I wonder if the same is occurring on Mac.