Audible click on sample stop

Latest version of Mirack running on 6th gen iPad. Headphone jack for output.

Greetings. I’ve been playing with audio for many years but I’m new to mirack and eurorack in general so please forgive me if I’m missing something obvious here.

I’m attempting to create a MIDI playable sampler with 16 slots, like a simplified MPC. If I re-trigger a sample while it is already playing, the interruption/stopping of the playing sample causes an audible click. It makes sense to me that stopping a wave cycle anywhere other than a zero crossing would cause a click… but this isn’t a problem I’ve run into with other software samplers. I’m not clear what the difference is that causes the audible click in my mirack setup.

Things I’ve tried to get rid of the click:

  • Tried almost all devices listed under Tags->Sampler to see if any can stop mid-cycle without clicking. They all seem to click on interrupt.
  • Played with the Click and Anti-click knobs. Maybe some improvement but still consistently reproducible click on interrupt.
  • Played with different Envelope devices. Seems like I should be able to stop that click with the right envelope settings but so far no luck.
  • tried using the Squinky Labs Slade. The description of Slade reads as if it was designed to resolve this issue but I don’t completely understand. I was able to wire this in a way that seemed to significantly reduce the likelihood of audio clicks… but not completely

I feel like there’s something simple I’m missing here. Maybe I just need to get my envelope setup correctly. Maybe related to gate vs. trigger of the Samplers. Or maybe mirack isn’t built for what I’m trying accomplish.

Any help/advice/guidance welcome and appreciated.

Hi @alvahsewell, welcome to virtual modular

I would say try a slew limiter on each audio output, like the one from bog audio instead of slade… Slade (I think) adds soft distortion. You only need at most half a second on rise and release times.

If that’s not working, then I would try the slew limiter on the gate/trigger just before samplers gate/trig input…

Let me know if either works for you and I will also try it out myself later.

all best


@Runcell Ty for the reply! I tried that bog slew limiter in-line with the audio output, in-line with a volume envelope, and on the trigger/gate before the sampler. None of those seemed to help. Since you mentioned Slew Limiter, I also tried the Befaco Rampage with the same configurations. When I use the Rampage inline with the sampler audio output, that does seem to remove the click but also adds a lot of distortion.

Here’s some additional info In case you or someone else wants to try and reproduce this to help me find a solution:
I’m using an Akai bluetooth MIDI controller and hitting the same pad rapidly at a random tempo. Rapidly because I need to re-trigger before the sample ends and random tempo so at least some of my triggers land mid wave cycle. I’m using a long 808 bass sample and I checked to make sure the click isn’t coming from that sample. As long as that sample plays from beginning to end uninterrupted, no click.

I think I need the MIDI trigger to completely attenuate the sampler audio out (with a VCA), then re-trigger the sample, then re-trigger the VCA with an envelope … and do all that fast enough so I don’t perceive the lag from trigger to audio… Is this what other software samplers do to prevent audio click on re-trigger? Or do they wait for a zero crossing before ending the playing sample? Also not sure if this is something I should be trying to solve thru fancy configuration in mirack or maybe I should turn this into a feature request for how the samplers work in mirack.

Thanks for the extra details @alvahsewell. The long 808 bass could be the issue.

I tried the slew limiter on audio outs, it doesn’t work, I should have realised it will distort the sound. Placing a slew on the gate/trigs won’t work either, it just delays the gate/trigs, like swing. So the only other option is to run each sampler out thru a VCA and control the VCA with an envelope, but that didn’t work out too great either… I realised it’s when the sample being played restarts whilst mid way into a bass drum hit… which is kind of what you’re trying. I also found that switching between different start points on beat gave less clicks/pops than when I randomly switched…
So I’m not too sure how to solve it really…! Or if it’s in the coding.

I will have another go with it and I’ll use an 808 bass heavy loop.

Hope you find a solution, if so post it up here and I will likewise

all best