Ableton Link not connecting

Hi! I’ve just started using miRack and love it! I’m wanting to link it to Ableton but the link is not being discovered in miRack. I’m using a PC for Ableton, not a Mac. Would that be the problem? My iPad and PC are on the same network. Am I missing something?

Thanks in advance!

Which version of miRack are you using?
I have the same problem using the last few Beta versions but the AppStore version is fine for me.


Hi Mark. Thanks for your response! I’m using the AppStore version. Everything works beautifully on the ipad. It’s just the Link that’s having a problem. It just keeps searching for an available connection.

hmm probable not the same issue then!
All i can suggest is what you’ve probably already tried :confused:
Make sure your ipad and other device are on the same network.
Check iOS settings for miRack to ensure Local Network is allowed. (I once was not given this option and had to hard reboot an iPad after which it appeared)
Link is switched on in miRack (Cpt Obvious here… sorry :))


I think if you are in the same WIFI network you can sync with you Ipad and pc … make sure of that, but , if I’m not wrong, the Bluetooth connectivity could work as well between your Ipad and your pc… a lease I been doing like that between Ipad and android phone… and it always work

There was an issue with a couple of Beta versions and appstore v 3.51
These have now been solved!